Errors: 112 or 3a12 after submitting the Certificate Signing Request (CSR) file during enrollment

Solution ID:    SO163
Version:    9.0
Published:    12/13/2007
Updated:    08/20/2014

Cause

 This problem occurs when an unrecognized file format is being submitted when entering the Certificate Signing Request (CSR) during enrollment. 
 
This error appears when the Certificate Signing Request (CSR) file contains invalid formatting, extra characters, or extra carriage returns, or if the request is not URL Encoded. Since the enrollment does a FORM POST, so the request needs to be URLEncoded to comply with HTTP Spec.
 

Solution

To resolve the error follow the steps below:
 
NOTE: If you are using Microsoft Windows 2000 Service Pack 1, obtain the latest Service Pack for Microsoft Windows 2000. Upgrading to the latest Service Pack will generate a PKCS10-formatted renewal request. This problem was first corrected in Microsoft Windows 2000 Service Pack 2.
 
For additional information, visit the following Microsoft Web site: http://support.microsoft.com/default.aspx?scid=kb;EN-US;260910 
 
1. Open the CSR in an ASCII text editor (Use Notepad or another plain text editor).
 
2. Ensure that the first line reads -----Begin New Certificate Request-----
 
3. Enable Word wrap. (In Notepad, select Format > Word Wrap.)
 
4. Carefully go through the text to ensure that there are no extra spaces or carriage returns (^M).
 
5. Ensure that every line of text is on a line of its own, and not combined with another line.
 
6. Re-submit the newly-formatted Certificate Signing Request (CSR)
 

Legacy ID

vs10960

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